• RPi4 Edition ベータテスト

    こんにちは

    Masterで動かない原因これですかね?
    snd-allo-boss-dac soc🔉 ASoC: no DMI vendor name!

    aliexpressで購入したんだけど、パチもん?

  • @パパリウス さん

    RPi4β版の公開有難うございます。遅ればせながら、本日テストさせていただくいました。結論から言えばRPi4 4GBで1.00β2は大きな問題なく音出しできています。
    dmesgでは2つエラーが出ていました。
    1)brcm-pcie fd500000.pcie: dmabounce: could not allocate 33554432 byte DMA pool
      brcm-pcie fd500000.pcie: could not init bounce buffers: -12
    2)CIFS VFS: ioctl error in smb2_get_dfs_refer rc=-22
    1)に関しては本日セットアップした1.00β2(4GB RPi4)では問題なく音がでていますので、必ずしも4GB RPi4の問題とは限らないような気がいたします。
    2)の原因は
    https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/fs/cifs?id=2564f2ff83975e05dbd2f13301f7147b63e67c91
    ではないかと思います。
    以上、本日のテスト結果をご報告させていただきました。

  • @knkn59 さま
    2)の件、そこまで追いきれていませんでした。
    (不要なエラーを吐いているって記述はググって見つけましたが...)

    カーネルソースはパパリウスさまが管理しているため、この記述確認いただき
    次回の更新で対応出来れば有り難いですね。

  • v1.0.0b3をオンラインアップデートで配信しました。

    <主な変更点>

    • Web UI (ympd)を差し替えました。

    Masterモードで動くはずのDACがSlaveになってしまうという現象が報告されていますが、事例が少なく切り分けに至っておりません。

    既に報告いただいた方以外に、同様の現象が発生しているかたはいらっしゃいますでしょうか?


    @mgroovy さん

    1. hifiberry-dacでmpd再生したあと
    2. rpi-dacでmpd再生したあと

    の2パターンのログを取得していただけませんでしょうか。
    違いを確認してみたいと思います。

  • 今晩は。すんなりb3へアップデートできました。
    そう言えばなんですが、タイトルリストのNEXT切り替えがきかないんですが。
    既出でしたらすいません。
    よろしくお願い致します。

  • パパリウスさんこんにちは。
    遅ればせながらRPi4β版へのテストに参加させていただきます。
    当方では以下の不具合が出ております。
    ・NASを認識後、UPDATE LIBRARYを実施。しばらくすると(ライブラリ更新終了時?)Connection refusedになりNASに接続できなくなります。
    ・1.0.0β1では発生しませんでした。β2以降だと発生しています。
    似たような症状はLightMPDでも発生しておりまして、当方の環境ではサーバーの直下にMUSICフォルダを作っていることが原因でした。ご参考になればと思います。

  • @knkn59 さん

    情報提供ありがとうございます。

    リンク先に紹介されているパッチの内容を確認しましたが、たしかにこのソース(smb2ops.c)が出力しているログでした。ただし、RPi4版のカーネルソース(4.19.86)には既に適用されているパッチだったことと、エラーコード異なっていたことから、少しちがう現象なのかもしれません。

    エラーコードは-22で、これはEINVAL(無効な引数)を意味しています。
    CIFSの仕様では、クライアントからのDFS照会を受け付けたCIFSサーバは、DFSから返されるエラーコードをそのままクライアントに返すと規定されているようです。

    https://docs.microsoft.com/en-us/openspecs/windows_protocols/ms-smb2/a9d1d0f9-0614-49f9-bf2e-021ce5cfcb2e

    宅内のCIFSサーバをDFS構成で運用されているかたはいらっしゃらないと思いますので、カーネルのCIFSモジュールのコンフィグを変更し、DFSサポートを無効にしてみようかなと思います。

  • @tyostd さん

    ご報告ありがとうございます。

    もう一度同じ操作を行ってログを取得していただけませんでしょうか。
    Connection refusedが発生したあとでsshログインし、
    /opt/plugins/91-support/run.sh
    を実行してください。

    ログを圧縮したファイルが下記に作成されます。
    /var/lib/mpd/music/RAM/support_log.tar.gz

    これをお送りいただければと思います。
    どうぞよろしくおねがい致します。

  • パパリウス様
    v1.0.0b3をクリックすると「your version is not supported.
    version check succeeded」が表示されてバージョンアップが出来ません。v1.0.0.b2も実行できていません。私のRPi4は4GBバージョンで中華から早期に購入したので認証されていないバージョンと思います。

  • @eric さん

    v1.0.0b1の不具合で、オンラインアップデートの取得先が古いままになっていました。

    下記コマンドで取得先を書き換えていただくと、オンラインアップデートが可能になります。

    sed -i s/ver=\"v0.9.x\"/ver=\"v1.0.0b\"/ /usr/local/bin/inplace_update.sh
    

    お手数をかけましてすみません。

  • RPi4 Edition ベータテストで@パパリウスが発言 :

    sed -i s/ver="v0.9.x"/ver="v1.0.0b"/ /usr/local/bin/inplace_update.sh

    パパリウス様
    有難うございます。無事v1.0.0.b3に移行が出来ました。素早い対応に感謝を申し上げます。

  • @パパリウス さま
    私でも対応出来る部分を見つけたので記載します。
    1)dmesg, jounalctlのエラーから

     /lib/systemd/system/dbus.socket:5: ListenStream= references a path below legacy directory /var/run/, updating /var/run/dbus/system_bus_socket → /run/dbus/system_bus_socket; please update the unit file accordingly.
    

    ログの通り /lib/systemd/system/dbus.socketの

    [Socket]
    ListenStream=/run/dbus/system_bus_socket
    

    に修正するだけでエラーが消えます。

    2)2バイト文字がNASの認識時に先頭に来る件(一部未解決)

    localectl set-locale LANG="ja_JP.utf8" LC_CTYPE="ja_JP"
    

    にて日本語ロケールを有効化してからシステムリブートし、
    mpc rescan NAS/ で再構築した結果、
    ごく一部のアルバムを除きフォルダ構成は正常に戻ったようです。

    しかしながら未だに上に居座ったまま残ったのはハングルという...
    (連れの歴史物ドラマのサントラ関係)

  • パパリウス様
    RPi4版対応ありがとうございます。
    PCM 352.8/24までの再生確認.
    DSDはDOP指定でノイズが出ます。(DDC(IAN CANADA)でDOPと認識していない模様)
    以上よろしくお願いいたします。

  • @sunatomo さん

    あー!なるほど。localeが絡んでましたか!
    これは助かりました。
    次にSDイメージを更新するときに対応しておこうと思います。

    @Ashra さん

    ご報告ありがとうございます。
    ちなみに、v0.9.6ではDoPも問題なく再生できてましたでしょうか?

  • @パパリウスさん

    ちなみに、v0.9.6ではDoPも問題なく再生できてましたでしょうか?
    同じ環境で再生できておりました。

  • @パパリウス さん

    あー!なるほど。localeが絡んでましたか!
    これは助かりました。
    次にSDイメージを更新するときに対応しておこうと思います。

    重箱の隅をつつくような指摘で恐縮ですが、大文字の後に小文字がくるような謎仕様もアルファベット順になってくれると嬉しいです。

    F86D4772-4264-4E3C-B4F8-4D5230F518D9.jpeg

    78C2B207-03FA-4C7D-966F-35BF4D3C3626.jpeg

  • パパリウスさん

    色々といじっていたら急に正常に戻りました!

    MPD の SoX Resampler Format のところが、設定していたと思っていたのですが、デフォルトのnoneになっていました。
    こちらを :32: に設定したところ、起動音、flac, dsf, Spotify, aplay すべて正常に動作しました。再度リブートして確認しても大丈夫でした。なおかつhifiberry-dac でも rpi-dac でも両方とも大丈夫でした。
    同じく動作しなかったもう一枚のSDCardを確認したところ、こちらもnoneの設定になっており、ここを修正したところ、すべて正常になりました。
    最初に*:32:*と設定した記憶はあるのですが。。。。

    なお、SOUND CARD の environment のDEFAULT_SAMPLE_FORMAT は S32 にしてありましたので、
    ここで不整合が発生してしまったのかも知れません。。。

    またまたお騒がせしてしまい、申し訳ありませんでした。

  • @Ashra さん

    貸し出し中の試聴機(SB32+PRO DoP)をご返却いただけることになりました。
    今週末にはDoPの動作を詳細に確認できると思いますので、どうぞお待ち下さい。


    @ジャイアン さん

    ご指摘ありがとうございます。
    大文字・小文字の並びも従来通りにしたいと思います。


    @mgroovy さん

    よかったです!
    もしかすると設定ファイルの更新がうまくいかないことがあるのかもしれませんね。

  • RPi4 Edition ベータテストで@パパリウスが発言 :

    @Ashra さん
    貸し出し中の試聴機(SB32+PRO DoP)をご返却いただけることになりました。
    今週末にはDoPの動作を詳細に確認できると思いますので、どうぞお待ち下さい。

    たかじんさんのサイトでDOPマーカーがつかないのはMPDのバグとの報告も

  • パパリウス様 昨夜v.1.0.0.b3に無事アップデートしてNASも読み込み完全な状態で聴けていました。寝る前にShutdownして今朝立ち上げたところ例のNo such file or directryエラーが出続けて使えません。この対策コマンドスクリプトを教えて頂けませんでしょうか?宜しくお願いいたします。