• RPi4 Edition ベータテスト

    すみません。
    appコマンドがバグっていました。

    お手数ですが、以下を実行してv1.0.0b2を上書きアップデートしてください。

    /usr/local/bin/inplace_update.sh
    
  • @sunatomo さん
    ありがとうございました。
    ご教示いただいた内容でインストールできました。

    パパリウスさん、ご対応ありがとうございます。
    改めて上書きアップデートしました。
    正常動作しております。

  • β2で以下を確認しました。

    aiffのタグ情報に対応しました

    ライブラリーアップデートを再度行いましたが、aiff音源のタグの内容は反映されないままです。

    mDNSの対応を強化しました

    NAS Settingで改めてホスト名による設定を試みました。
    今度はpingが通ったようです。
    しかし、別の問題が起こっているようです。
    以下その結果内容です。

    updating fstab start!!
    Checking ping reply to music.local

    Checking cifs security mode and protocol version
    !!!Can not resolve the security mode or protocol version.
    Aborting the process!!!
    check succeeded

    IPアドレスを使うと問題なく設定できます。

    updating fstab start!!
    Checking ping reply to 192.168.3.6

    Checking cifs security mode and protocol version
    security mode and protocol version: sec=ntlmssp,vers=2.1

    Checking best rsize

    rsize BW CTX latency
    7300 10675 2464 370
    16060 11342 828 349
    32120 11408 359 347
    61320 11435 188 347
    129940 11303 96 351

    best bandwidth : 11435 kB/sec

    fstab setting : //192.168.3.6/USB/music_data /var/lib/mpd/music/NAS cifs ro,noauto,x-systemd.automount,sec=ntlmssp,vers=2.1,rsize=61320,cache=none,iocharset=utf8,username=xxx,password=xxx
    Restarting mpd and mounting NAS with new setting

    NAS setting succeeded

  • @パパリウス さま
    inplace_update.sh直打ちの際に

    cp: -r not specified; omitting directory './etc/bash_completion.d'
    

    が気になり/etc/bash_completion.dを見てみたところ
    ethtoolが当該ディレクトリにありましたが/usr/binに移動したほうが良いですよね?

    また、本日気づいた事項について追加報告になります。

    ①Cantataでライブラリ構成の確認を行ったところ、mp3ファイルのid3タグが認識出来ていない模様です(ファイル名でライブラリ登録)。
    β2導入後にライブラリの再更新を行いましたが変化なしです。
    恐らくジャイアン さまと同じくβ2にてid3tagを追加頂いたのですが既存ライブラリの更新が上手く言っていない可能性があるかもしれません。
    (必要であればtag_cache一度強制削除して再構築します)

    ②WebUIでのConsumeが上手く動作していないようです。
    Consumeボタンを押した後も/var/lib/mpd/statusはconsume :0で変わっていませんでした。

    上記2項とも私的にはパパリウスさまの希望順で対応頂ければと思います。

  • @ジャイアン さん

    再検証していただきありがとうございます。
    こちらでも再確認してみます。

    @sunatomo さん

    bash_completion.dのethtoolは、中身はbashスクリプトですので、そのまま場所で大丈夫です。
    次回はcp -r のワーニングが出ないように直しておきます。


    ライブラリの更新は2通りの方法があります。
    mpc update NAS/
    ⇨更新されたファイルのみタグを取り込み(Web UIからのライブラリアップデートはこちら)

    mpc rescan NAS/
    ⇨更新されてないファイルも含めて全てのタグを再取り込み

    Web UIからはrescanできませんので、sshでログインしてmpcを叩いてもらうと早いかと思います。


    Consumeボタンの件、確認してみます。

  • >パパリウス様、サポートしてくださる皆様

    精力的な開発とサポートいつもありがとうございます。

    sunatomo様の投稿を参考にβ2へのアップデートが完了いたしました。
    とてもよい音が出ております。

    現状で気づいた点といたしましては、
    ・ラズパイの再起動後にメニューが「DASHBOARD」と「SETTINGS」しか表示されない
     ⇒ブラウザリロードすればきちんと表示されます。

    ・Spotifyの再生ができない

    わかる範囲で確認したところ
     ・4GBモデル特有のエラー?が発生している
     ・rc-local.serviceがコケている

    その他
     ・規格外の話と思いますので、優先順位は低くて構わないのですが .wavのタグが表示されない(β1のaiffと同じ表示)

    こちらの環境
     ラズパイ4 4GBモデル
     DAC: Applepi DAC

    ご報告まで。

  • RPi4 Edition ベータテストで@パパリウスが発言 :

    mpc rescan NAS/
    ⇨更新されてないファイルも含めて全てのタグを再取り込み
    Web UIからはrescanできませんので、sshでログインしてmpcを叩いてもらうと早いかと思います。

    rescanの実行でAIFF音源のタグがチャンと読み込まれる事を確認しました。
    ありがとうございます!

  • @パパリウス さま

    mpc rescan NAS/ の件、助かりました。
    今回のβ2では上記コマンドで私の環境ではmp3は全てタグ認識いたしました。
    (ジャイアン さまと同じくこれで解決したと思います。)
    あとは、NASでの並び順が2バイト文字が先頭になる件が元に戻れば文句なしです。

    @KSK さま他、既にベータを導入している方で楽曲ファイルのタグが正常認識できていない方は
    是非実行してみて下さい。

  • RPi4 Edition ベータテストで@KSKが発言 :

    ・4GBモデル特有のエラー?が発生している

    mgroovy です。報告し忘れていました。
    私も4GBモデルの技適マーク付きのを購入しておりました。

    確か flyingaceさんとRPi4B以降の接続構成は同じなのに、なぜ私の構成では正常に再生しないのかと不思議に思っていました。
    今確認してみたところ、flyingaceさんのは2GBモデルと記載されていらっしゃいますね。
    ということで、KSKさんがおっしゃっている、4GBモデル特有のエラー?が発生しているというのが、私のところでも出ている現象なのかな?と思いました。

  • @ジャイアン さん @sunatomo さん

    検証ありがとうございます。
    mp3やaiffなどid3tagでタグを格納しているものは、β2で解決できたようですね。


    @KSK さん
    rc-localがこけたあとで、サポートプラグインでログをとって送っていただけませんでしょうか。
    どうぞよろしくおねがい致します。


    @mgroovy さん

    KSKさんからログをいただいてから、もう一度作戦を練ってみましょう。

  • @パパリウス様、@sunatomo様

    - .wavのタグが表示されない件
     rescanしたところ、正常に表示できることを確認できました。
     ありがとうございました。

    -4GBモデル特有のエラー?
     エラーメッセージの中の”dmabounce: could not allocate 33554432 byte DMA pool”について検索したところ
     4GBモデルについて書かれているページが多かったため、そう判断いたしました。

    お礼を兼ねまして、ご報告まで。

  • パパリウスさん、aiffのタグを取得できるようになりました。
    ありがとうございます。
    ライブラリのソート順はまだ解決されていないという理解で良いでしょうか?

  • DSD音源(dsfファイル)MPDクライアントからも見えるようになりました。またethtoolの件、早速のご対応いただき恐縮です。

    LAN速度ですがDB更新時は1Gで、リスニング時は100Mとしています。DSDtoPCM再生も全く問題なく安定しています。

    なお、音楽を聴く心地良さ、この上ないです!

  • こんにちは

    Masterで動かない原因これですかね?
    snd-allo-boss-dac soc🔉 ASoC: no DMI vendor name!

    aliexpressで購入したんだけど、パチもん?

  • @パパリウス さん

    RPi4β版の公開有難うございます。遅ればせながら、本日テストさせていただくいました。結論から言えばRPi4 4GBで1.00β2は大きな問題なく音出しできています。
    dmesgでは2つエラーが出ていました。
    1)brcm-pcie fd500000.pcie: dmabounce: could not allocate 33554432 byte DMA pool
      brcm-pcie fd500000.pcie: could not init bounce buffers: -12
    2)CIFS VFS: ioctl error in smb2_get_dfs_refer rc=-22
    1)に関しては本日セットアップした1.00β2(4GB RPi4)では問題なく音がでていますので、必ずしも4GB RPi4の問題とは限らないような気がいたします。
    2)の原因は
    https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/fs/cifs?id=2564f2ff83975e05dbd2f13301f7147b63e67c91
    ではないかと思います。
    以上、本日のテスト結果をご報告させていただきました。

  • @knkn59 さま
    2)の件、そこまで追いきれていませんでした。
    (不要なエラーを吐いているって記述はググって見つけましたが...)

    カーネルソースはパパリウスさまが管理しているため、この記述確認いただき
    次回の更新で対応出来れば有り難いですね。

  • v1.0.0b3をオンラインアップデートで配信しました。

    <主な変更点>

    • Web UI (ympd)を差し替えました。

    Masterモードで動くはずのDACがSlaveになってしまうという現象が報告されていますが、事例が少なく切り分けに至っておりません。

    既に報告いただいた方以外に、同様の現象が発生しているかたはいらっしゃいますでしょうか?


    @mgroovy さん

    1. hifiberry-dacでmpd再生したあと
    2. rpi-dacでmpd再生したあと

    の2パターンのログを取得していただけませんでしょうか。
    違いを確認してみたいと思います。

  • 今晩は。すんなりb3へアップデートできました。
    そう言えばなんですが、タイトルリストのNEXT切り替えがきかないんですが。
    既出でしたらすいません。
    よろしくお願い致します。

  • パパリウスさんこんにちは。
    遅ればせながらRPi4β版へのテストに参加させていただきます。
    当方では以下の不具合が出ております。
    ・NASを認識後、UPDATE LIBRARYを実施。しばらくすると(ライブラリ更新終了時?)Connection refusedになりNASに接続できなくなります。
    ・1.0.0β1では発生しませんでした。β2以降だと発生しています。
    似たような症状はLightMPDでも発生しておりまして、当方の環境ではサーバーの直下にMUSICフォルダを作っていることが原因でした。ご参考になればと思います。

  • @knkn59 さん

    情報提供ありがとうございます。

    リンク先に紹介されているパッチの内容を確認しましたが、たしかにこのソース(smb2ops.c)が出力しているログでした。ただし、RPi4版のカーネルソース(4.19.86)には既に適用されているパッチだったことと、エラーコード異なっていたことから、少しちがう現象なのかもしれません。

    エラーコードは-22で、これはEINVAL(無効な引数)を意味しています。
    CIFSの仕様では、クライアントからのDFS照会を受け付けたCIFSサーバは、DFSから返されるエラーコードをそのままクライアントに返すと規定されているようです。

    https://docs.microsoft.com/en-us/openspecs/windows_protocols/ms-smb2/a9d1d0f9-0614-49f9-bf2e-021ce5cfcb2e

    宅内のCIFSサーバをDFS構成で運用されているかたはいらっしゃらないと思いますので、カーネルのCIFSモジュールのコンフィグを変更し、DFSサポートを無効にしてみようかなと思います。